A place to have fun with Mugen
 
PortalHomeFAQMemberlistSearchRegisterComic WIP TrackerDownloadsLog inChat
Website Navigation Help
Translate the Website
Log in
Username:
Password:
Log in automatically: 
:: I forgot my password
Latest topics
» Stan Smith Spritesheet for Warner
by borewood2013 Today at 1:28 pm

» Happy ~Birthday~ to ***Atiles ***
by borewood2013 Today at 1:21 pm

» Jewelry Exhibition 1.1 & 1.0
by borewood2013 Today at 12:43 pm

» TK's Mugen Saturday Slamfest
by TK830515 Today at 12:07 pm

» THE KING OF FIGHTERS: DESTINY (updated to EP.16)...........now can be watched at YouTube!
by borewood2013 Today at 11:39 am

» Anyone remember the browser anime tcg game Star Era?
by borewood2013 Today at 11:22 am

Special Features at MMV






Chat on MMV w/ Discord


Share | 
 

 Teleport problem

View previous topic View next topic Go down 
AuthorMessage
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Teleport problem   October 26th 2015, 10:09 am

Hello, I need some help with my Teleport move. I created a teleport move properly but as i created and imported those codes in it.. so now it wont execute any other move HP,MP,MK... he only dose go forward, back, jump and teleporting, what did i do wrong?
Back to top Go down
View user profile
Chimoru

avatar

Posts : 597
Join date : 2012-06-05
Age : 36
Location : Detroit

PostSubject: Re: Teleport problem   October 26th 2015, 4:56 pm

Zox, I would love to help you, but I'll probably need a little more data to work with.

Sometimes where you place the commands in the CMD also affects the priority of which ones will trigger first. I know it makes no sense when I say it like that, but sometimes when I take the command codes and move them around (higher or lower) in the CMD, they begin to respond better. Maybe this is your problem?
Back to top Go down
View user profile
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Re: Teleport problem   October 26th 2015, 5:34 pm

I fixed it.. it was in command. i didnt added comands to right place.
Thanks anyway for your reply. Very Happy
Back to top Go down
View user profile
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Re: Teleport problem   October 26th 2015, 6:23 pm

How can i make that he also can teleport in air.. where is that code
Back to top Go down
View user profile
Mistah Jorge

avatar

Posts : 2016
Join date : 2013-07-04
Age : 19
Location : Portugal

PostSubject: Re: Teleport problem   October 26th 2015, 7:26 pm

remove something like this in the comands section "statetype !=A" that should work
Back to top Go down
View user profile
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Re: Teleport problem   October 26th 2015, 7:43 pm

;Teleport
[Statedef 1200]
type = S
movetype= A
physics = S
juggle = 4
velset = 0,0
anim = 199
ctrl = 0
sprpriority = 2

[State 1200, 1]
type = PlaySnd
trigger1 = AnimElem = 1
value = 10,9

[State 1200, 2]
type = ChangeState
trigger1 = AnimTime = 0
value = 1201
ctrl = 1

[Statedef 1201]
type = S
movetype= A
physics = S
juggle = 4
velset = 0,0
anim = 1980
ctrl = 1
sprpriority = 2

[State 1201, 0]
type = Posset
trigger1 = 1
y = 0

[State 1201, Turn]
type = Turn
trigger1 = p2dist X <= 0

[State 1201, 1]
type = PlaySnd
trigger1 = AnimElem = 1
value = 10,9

[State 1201, 1]
type = PosAdd
trigger1 = Time = 0
x = p2bodydist X + 150

[State 1201, 2]
type = ChangeState
trigger1 = AnimTime = 0
value = 0
ctrl = 1




------------------------------------



[statedef -1]


; Teleport
[State -1]
type = ChangeState
value = 1200
triggerall = statetype = S
triggerall = command = "teleport"
trigger1 = ctrl = 1
trigger2 = stateno = 200 && MoveContact
trigger3 = stateno = 230 && MoveContact
trigger4 = stateno = 210 && MoveContact
trigger5 = stateno = 240 && MoveContact
trigger6 = stateno = 220 && MoveContact
trigger7 = stateno = 250 && MoveContact
Back to top Go down
View user profile
Chimoru

avatar

Posts : 597
Join date : 2012-06-05
Age : 36
Location : Detroit

PostSubject: Re: Teleport problem   October 26th 2015, 8:22 pm

; Teleport
[State -1]
type = ChangeState
value = 1200
triggerall = statetype = S
triggerall = command = "teleport"
trigger1 = ctrl = 1
trigger2 = stateno = 200 && MoveContact
trigger3 = stateno = 230 && MoveContact
trigger4 = stateno = 210 && MoveContact
trigger5 = stateno = 240 && MoveContact
trigger6 = stateno = 220 && MoveContact
trigger7 = stateno = 250 && MoveContact


This part here means he has to be Standing for the code to work.

If it was an A, then it would mean in the air, but then it wouldn't work if he was standing.

You need a code that works for both S & A
Back to top Go down
View user profile
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Re: Teleport problem   October 27th 2015, 7:42 am

ok thanks.. i copy the entire animation and added a second one, added the same button combination and in Air teleport added triggerall = statetype = A
Back to top Go down
View user profile
Blade

avatar

Posts : 406
Join date : 2012-11-07

PostSubject: Re: Teleport problem   October 28th 2015, 2:03 pm

..
Back to top Go down
View user profile
 
Teleport problem
View previous topic View next topic Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
The Mugen Multiverse :: Mugen :: Mugen Help-
Jump to: